Login  |  Sign up
Posts
Views: 621|Reply: 3

Stuck trying to Access W18-LYRA [Copy the link of this thread]

Rank: 3

Post Time: 2-6-2015 06:50:48 AM |Show all posts
Hey guys,

I was jumping between servers last night - and I noticed that W18-LYRA was an available option to select - being curio - I selected it. When it tried logging in - I got the 'Server is under maintenance' pop-up. Thats fine - but I hear that they are no longer available as options for current players.

I have no way of returning to W14 - where I have just bee made leader of an alliance and have a station I do not wish t lose. I am running a windows icon phone, using Wndows 8.0. I do not believe there is a way I can uninstall and reinstall the game without losing all I've worked so hard for.

I have also spent real money helping the station along - and do not want to see that wasted.

Is there anyway my acct can be forced to look for W14, W13 or W15 again - so i can get back on - or do I have to wait now for the roll out of W18....the game said it was available - and now I can't play.

I believe that the developers/Joyfort are in error here which caused me to be in this situation, and need your help getting it resolved so I can continue playing the game daily.

please contact me and I will provide my W14 username, or W15.

Use magic Report

Rank: 1

Post Time: 2-7-2015 08:10:09 AM |Show all posts
Post edited by Graeme038 at 2-7-2015 08:11 AM

I know your pain.    I've had the same issue, also on the windows 8 phone.  Started the game yesterday, noticed that there were 3 new servers available, clicked to join w17 and am now stuck with it trying to join a server that is in constant maintenance.

Have tried uninstalling, reinstalling.  Resetting phone etc but as soon as you hook back into the xboxlive account it retains the settings and the game tries to auto join w17.

Use magic Report

Rank: 3

Post Time: 2-7-2015 09:10:28 AM |Show all posts
Graeme038 wrote 2-7-2015 08:10 AM
I know your pain.    I've had the same issue, also on the windows 8 phone.  Started the game yesterd ...

Yeah - if they can just make w18 available for a 5 minute window etc - then we can repoint our acts to a different world. Its a great game and I have advanced levels across the board - I don't want to lose that.

Did you open a ticket with them? I did when i posted this - no response yet. Even if I could save data with an upgrade to windows 8.1 (not available for my icon) - the game data would save - but I have a feeling I will be pointed back to w18.

This should be an easy fix...very annoying...very frustrating.

Use magic Report

Rank: 2Rank: 2

Post Time: 2-8-2015 06:18:52 AM |Show all posts
Post edited by i_14152882423 at 2-8-2015 06:19 AM

Same problem here : wanted to test the W16, stuck on it when loading and no way to get back to my W12

WTF joyfort???

Use magic Report

You have to log in first before reply Log In | Sign Up

Copyright (c) 2010 - 2013 JOYFORT ENTERTAINMENT LIMITED. All Rights Reserved           About Us | Contact Us | Terms of Service | Privacy Policy
Back to top